Автор Тема: І все таки воно не працює!(тедефон->USB->інтернет)  (Прочитано 4285 раз)

Offline Дімон

  • Newbie
  • *
  • Повідомлень: 18
  • Karma: 0
Підключив телефон
Ввів dmesg
Налаштував /etc/wvdial.conf :

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"IP","3g.utel.ua"
Stupid Mode = 1
ISDN = 0
Modem Type = USB Modem
New PPPD = yes
Phone = *99#
Modem = /dev/ttyACM0
Username = utel
Password = utel
Baud = 460800

Ввів  wvdial :

l@Gonchariuk:~$ wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","3g.utel.ua"
AT+CGDCONT=1,"IP","3g.utel.ua"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
~[7f]}#@!}!}!} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&Zs;F9/~
--> Carrier detected.  Starting PPP immediately.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
~[7f]}#@!}!}"} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&Zs;FuB~~[7f]}#@!}!}#} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&Zs;F1}9~~[7f]}#@!}!}$} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&Zs;F|[11]~~[7f]}#@!}!}%} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&Zs;F8J~~[7f]}#@!}!}&} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&Zs;Ft'~~[7f]}#@!}!}'} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&Zs;F0|~~[7f]}#@!}!}(} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&Zs;F[7f]>~~[7f]}#@!}!})} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&Zs;F;e~~[7f]}#@!}!}*} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&Zs;Fw[08]~
NO CARRIER
--> No Carrier!  Trying again
(Не підключається)

Ввів sudo wvdial :

l@Gonchariuk:~$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","3g.utel.ua"
AT+CGDCONT=1,"IP","3g.utel.ua"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
~[7f]}#@!}!}!} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&](^}*rd~
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Thu Dec 18 13:12:24 2008
--> Pid of pppd: 5679
--> Using interface ppp0
--> pppd: ?g[06] ?p[06] ?g[06]
--> pppd: ?g[06] ?p[06] ?g[06]
--> pppd: ?g[06] ?p[06] ?g[06]
--> pppd: ?g[06] ?p[06] ?g[06]
--> pppd: ?g[06] ?p[06] ?g[06]
--> pppd: ?g[06] ?p[06] ?g[06]
--> pppd: ?g[06] ?p[06] ?g[06]
--> local  IP address 94.179.197.41
--> pppd: ?g[06] ?p[06] ?g[06]
--> remote IP address 10.64.64.64
--> pppd: ?g[06] ?p[06] ?g[06]
--> primary   DNS address 195.5.46.12
--> pppd: ?g[06] ?p[06] ?g[06]
--> secondary DNS address 195.5.46.10
--> pppd: ?g[06] ?p[06] ?g[06]
(На мобільному підключення встановлене(планета з"явилася), а в браузері сайти не відкриваються)

Ще є гілка "Допоможіть встановити частоту оновлення монітора" http://forum.ubuntu.kiev.ua/index.php?topic=351.15 -не минайте

Offline CosmonauT

  • Newbie
  • *
  • Повідомлень: 2
  • Karma: 0
Є таке з people.net і телефончиком ZTE Evolution (у мене). Вдається, поки-що, перемогти цю штуку тільки методом витягнув-впихнув телефон у USB :(

По-моєму, якийсь баг у софті, але ще не розбирався.
« Останнє редагування: 2008-12-21, 10:33:55 від CosmonauT »

Offline omega

  • Newbie
  • *
  • Повідомлень: 1
  • Karma: 0
Ребята все просто, у вас не поднимается шлюз по умолчанию, в вашем логе есть строка:
remote IP address 10.64.64.64
можно просто прописать после того как поднялось соединение:
route add default gw 10.64.64.64

Offline zipchik

  • Newbie
  • *
  • Повідомлень: 2
  • Karma: -1
Ахаха... там надо,в браузере убрать автономный режым!