Автор Тема: Інтернет в 8.10 через авторизатор  (Прочитано 4215 раз)

Offline S_Arhangel

  • Newbie
  • *
  • Повідомлень: 39
  • Karma: 0
Привіт. Встановив собі Ubuntu 8.10 і тепер неможу налаштувати інтернет.
Ввів свій IP, маску, шлюз, а далі потрібно запустити авторизатор... Він існує в вигляді скрипту на перлі(прикріплюю).
В Ubuntu 8.04 робив так: sudo perl noauth.pl  ... далі отримую помилку щодо Crypt Rijndael ...потім знаходжу і встановлюю libcrypt-rijndael-perl  після чого тією ж командою запускаю і все працює! Є інет.
АЛЕ в 8.10 так невиходить!!! Початок такий самий: sudo perl noauth.pl ,потім повідомлення що невистачає Rijndael. Шукаю і знаходжу libcrypt-rijndael-perl_1.07-1_i386.deb. Пробую встановити і бачу напис що цей пакунок чи то непотрібен чи непідтримується теперішнім Перлом і встановити неможливо... ???
Може в новій убунті цю бібліотеку (чи що там воно) замінено на іншу? Думаю так бо помітив в репозиторії щось схоже : libcrypt-blowfish-perl_2.10-1build2_i386.deb. Встановив це але тепер потрібно переписувати скрипт  :(  Спробував в ньому (в скрипті) замінити всі  Rijndael на Blowfish (перше що спало на думку).... потім скрипт начебто запустивсь але випала помилка "відносно лістингу скрипту" ...
Коротше кажучи -  непрацює. Прошу поради

Offline mikhalek

  • Jr. Member
  • **
  • Повідомлень: 87
  • Karma: 1
  • Don't worry, be ukrainian!
А не простіше попросити у провайдера відключити авторизатор для Вас і користуватись нетом напряму, я так зробив і відпала потреба танців з бубнами... Уже другий рік пішов і все працює. :)

Offline S_Arhangel

  • Newbie
  • *
  • Повідомлень: 39
  • Karma: 0
Ну... я так собі думаю що авторизатор потрібен для чогось.... наприклад для "білінгу" чи щось ще... Хіба ні?

Значть так, зміг запустити цей скрипт(таки знайшовши підходящий Rijndael)...але чим далі в ліс як то кажуть тим цікавіше. Авторизація проходить а інету нема! Спробував іншим способом: через wine запустив віндовський авторизатор...в ньому теж авторизація проходить, навіть отримується статистика трафіку/стан рахунку з сервера а інету всеодно немає!!
Як так?  Що скажете?

Offline S_Arhangel

  • Newbie
  • *
  • Повідомлень: 39
  • Karma: 0
 :D опа. Все вирішилось додаванням ще DNS сервера (написав те саме що й в шлюз)....дивно, здавалось мені що в мого провайдера ДНС невикористовується ...

Щоб вже не даремно створювалась тема маю ще питання:
авторизатор запустив з wine і все наче працює тільки некоректно відображаються росіянські літери. Мабуть потрібно якось налаштовувати сам wine... А як?

Offline swift

  • Administrator
  • Hero Member
  • *****
  • Повідомлень: 549
  • Karma: 7
знайди в ~/.wine директорію fonts та помісти туди шрифти з windows
/dev/null > /dev/snd

Offline S_Arhangel

  • Newbie
  • *
  • Повідомлень: 39
  • Karma: 0
Зробив так: сюди /.wine/drive_c/windows/Fonts/    скопіював все що було тут С:\WINDOWS\Fonts... Після перезавантаження нічого не змінилось...кирилиця не відображається. Проте не вся...прикріплюю скрін

AZCat

  • Гість
404..
значить не всі шрифти скинув..
PS
wget http://www.kegel.com/wine/winetricks
chmod +x winetricks
./winetricks allfonts

Offline mikhalek

  • Jr. Member
  • **
  • Повідомлень: 87
  • Karma: 1
  • Don't worry, be ukrainian!
Ну... я так собі думаю що авторизатор потрібен для чогось.... наприклад для "білінгу" чи щось ще... Хіба ні?


Я думав мова йде про безліміт...

Offline S_Arhangel

  • Newbie
  • *
  • Повідомлень: 39
  • Karma: 0
to Kotyara
спробував...встановились....але нічого не змінилось. Картинка та сама

AZCat

  • Гість
to Kotyara
спробував...встановились....але нічого не змінилось. Картинка та сама

"404 - Вкладення не знайдено"
перезалий плз.